BumpMap Class


Bump Map Class

A static class that provides access to the property names that appear in the BumpMap visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual BumpMap

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class BumpMap

The BumpMap type exposes the following members.

Properties
Name Description
Public property Static member BumpmapBitmap The property labeled "Source" from the "BumpMap" schema.
Public property Static member BumpmapDepth The property labeled "Amount" from the "BumpMap" schema.
Public property Static member BumpmapNormalScale The property labeled "Amount" from the "BumpMap" schema.
Public property Static member BumpmapType The property labeled "Bump Type" from the "BumpMap" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "BumpMap" schema.
Public property Static member TextureOffsetLock The property labeled "Offset Lock" from the "BumpMap" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "BumpMap" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "BumpMap" schema.
Public property Static member TextureRealWorldScaleX The property labeled "Size X" from the "BumpMap" schema.
Public property Static member TextureRealWorldScaleY The property labeled "Size Y" from the "BumpMap" schema.
Public property Static member TextureScaleLock The property labeled "Scale Lock" from the "BumpMap" schema.
Public property Static member TextureURepeat The property labeled "U Repeat" from the "BumpMap" schema.
Public property Static member TextureVRepeat The property labeled "V Repeat" from the "BumpMap" schema.
Public property Static member TextureWAngle The property labeled "Angle" from the "BumpMap" schema.
Top
See Also