IsADirectContext3DHandleType Method


Direct Context 3DDocument Utils Is ADirect Context 3DHandle Type Method

Checks whether the provided Element ID corresponds to a DirectContext3D handle type element.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsADirectContext3DHandleType(
	Document aDocument,
	ElementId elementId
)

Parameters

aDocument Document
The document.
elementId ElementId
The ID of the element to check.

Return Value

Boolean
True, if the element is a valid DirectContext3D handle type, false otherwise.
Exceptions
Exception Condition
ArgumentException aDocument is not a project document. -or- elementId is not a valid Element identifier.
ArgumentNullException A non-optional argument was null
Remarks

DirectContext3D handle types are DirectShapeTypes.

See Also