Speckle Class


Speckle Class

A static class that provides access to the property names that appear in the Speckle visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual Speckle

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class Speckle

The Speckle type exposes the following members.

Properties
Name Description
Public property Static member SpeckleColor1 The property labeled "Color 1" from the "Speckle" schema.
Public property Static member SpeckleColor2 The property labeled "Color 2" from the "Speckle" schema.
Public property Static member SpeckleSize The property labeled "Size" from the "Speckle" schema.
Public property Static member TextureAngle The property labeled "Angle" from the "Speckle" schema.
Public property Static member TextureLinkTextureTransforms The property labeled "Link Transforms" from the "Speckle" schema.
Public property Static member TextureRealWorldOffsetX The property labeled "Offset X" from the "Speckle" schema.
Public property Static member TextureRealWorldOffsetY The property labeled "Offset Y" from the "Speckle" schema.
Public property Static member TextureRealWorldOffsetZ The property labeled "Offset Z" from the "Speckle" schema.
Top
See Also