GetAssociatedParts Method (Document, ElementId, Boolean, Boolean)


Part Utils Get Associated Parts(Document, Element Id, Boolean, Boolean) Method

Returns all Parts that are associated with the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetAssociatedParts(
	Document hostDocument,
	ElementId elementId,
	bool includePartsWithAssociatedParts,
	bool includeAllChildren
)

Parameters

hostDocument Document
The document of the element.
elementId ElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts Boolean
If true, include parts that have associated parts.
includeAllChildren Boolean
If true, return all associated Parts recursively for all children. If false, only return immediate children.

Return Value

ICollection ElementId
Parts that are associated to the element.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also