NewLoftForm Method


Family Item Factory New Loft Form Method

Create new Form element by Loft operation, and add it into the Autodesk Revit family document.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Form NewLoftForm(
	bool isSolid,
	ReferenceArrayArray profiles
)

Parameters

isSolid Boolean
Indicates if the Form is Solid or Void.
profiles ReferenceArrayArray
The profile set of the newly created loft. Each profile should consist of only one curve loop.

Return Value

Form
If creation was successful form is are returned.
See Also