AppearanceAssetEditScope Class


Appearance Asset Edit Scope Class

A scope object that provides special access and limitations related to editing appearance assets and their related elements.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AppearanceAssetEditScope

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AppearanceAssetEditScope : IDisposable

The AppearanceAssetEditScope type exposes the following members.

Constructors
Name Description
Public method AppearanceAssetEditScope Constructs a new instance of an AppearanceAssetEditScope.
Top
Properties
Name Description
Public property IsActive Identifies if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Cancel Cancels the edit scope.
Public method Commit Finishes the edit scope.
Public method Dispose Releases all resources used by the AppearanceAssetEditScope
Public method Start Starts the edit scope.
Top
Remarks
You can use an AppearanceAssetEditScope to modify the values of the properties of appearance assets and connected assets (such as bitmaps). The following restrictions apply:
  • A single edit scope is allowed only to edit one top level rendering assets (and its connected assets). To edit more than one appearance asset you must start a different edit scope.
  • An edit scope may be reused for editing another asset, so long as it has been committed or canceled before using start to associate it to a new asset.
  • Multiple changes to the asset are allowed before commit.
  • A transaction must be started before using Commit() on the edited asset. The transaction may be opened before or after the edit scope is started, but must be open to allow the changes into the model.
See Also