IPerformance |
Retrieves a filter to restrict elements to be checked.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- document Document
- Document for which performance problems are being checked.
Return Value
ElementFilterThe filter to restrict elements to be checked.

If the rule needs to be executed on individual elements, it should return a filter that defines what elements the rule should apply to. Otherwise, nothing (i.e. null) should be returned. If filter is returned, it should stay valid till the end of the check.