Rebar |
Gets the distance from the RebarConstrainedHandle to the target Rebar handle surface. The RebarConstraintType of the RebarConstraint must be 'ToOtherRebar'.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Return Value
DoubleReturns the distance from the RebarConstrainedHandle to the target Rebar handle surface.

Exception | Condition |
---|---|
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |

Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.