View Get |
Gets graphic overrides that a filter applies to the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- filterElementId ElementId
- ElementId of the filter.
Return Value
OverrideGraphicSettingsObject representing all graphic overrides of the filter in the view.

Exception | Condition |
---|---|
ArgumentException | ElementId is not associated with a FilterElement. -or- Filter is not applied to the view. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The element "this View" does not belong to a project document. -or- The view type does not support Visibility/Graphics Overriddes. |