GetDesignElementAndFabricationPartsWithDifferentOffsets Method


Design To Fabrication Converter Get Design Element And Fabrication Parts With Different Offsets Method

Gets the collection of design elements that failed to convert and the associated set of fabrication parts with different offsets.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IDictionary<ElementId, ISet<ElementId>> GetDesignElementAndFabricationPartsWithDifferentOffsets()

Return Value

IDictionary ElementId , ISet ElementId
A map of design element identifiers that were not converted and the associated set fabrication parts left with different offsets.
Remarks
This set of element identifiers is only available after the Convert method has been invoked, and returns DesignToFabricationConverterResult::Enum::PartialFailure.
See Also