SetMajorLayoutAsActualSpacing Method


Fabric Sheet Type Set Major Layout As Actual Spacing Method

Sets the major layout pattern as ActualSpacing, while specifying the needed parameters for this pattern.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetMajorLayoutAsActualSpacing(
	double overallWidth,
	double minorStartOverhang,
	double spacing
)

Parameters

overallWidth Double
The entire width of the wire sheet in the minor direction.
minorStartOverhang Double
The distance from the edge of the sheet to the first wire in the minor direction.
spacing Double
The distance between the wires in the major direction.
Exceptions
Exception Condition
ArgumentException The given value for overallWidth is not a number -or- The given value for minorStartOverhang is not a number -or- The given value for spacing is not a number -or- The arguments are not consistent, please specify proper input values.
ArgumentOutOfRangeException The given value for overallWidth must be greater than 0 and no more than 30000 feet. -or- The given value for minorStartOverhang must be between 0 and 30000 feet. -or- The given value for spacing must be greater than 0 and no more than 30000 feet.
See Also