AddTrigger Method (UpdaterId, ElementFilter, ChangeType)


Updater Registry Add Trigger(Updater Id, Element Filter, Change Type) Method

Adds trigger with the specified element filter and ChangeType for all documents associated with this Updater

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void AddTrigger(
	UpdaterId id,
	ElementFilter filter,
	ChangeType change
)

Parameters

id UpdaterId
Id of updater that trigger should be added to
filter ElementFilter
Element filter that defines elements that affect this trigger
change ChangeType
ChangeType associated with this trigger
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The updater's owner's AddIn does not match the currently active AddIn. -or- The id does not correspond to any registered Updaters. -or- AddTrigger called while executing an updater.
Remarks
This method only works with CategoryFilter and ParameterFilter.
See Also