Formatted |
Returns a text range identifying the first occurrence of the given string within the text, starting from a given index.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public TextRange Find(
string searchString,
int startIndex,
bool matchCase,
bool matchWholeWord
)
Parameters
- searchString String
- The text to search for.
- startIndex Int32
- The start index to search within the text.
- matchCase Boolean
- True if the case must match when searching the formatted text, false to search in a case-insensitive manner.
- matchWholeWord Boolean
- True if the match must be a whole word when searching the formatted text, false otherwise.
Return Value
TextRangeThe text range identified.

Exception | Condition |
---|---|
ArgumentException | searchString is an empty string. -or- searchString contains invalid characters such as a newline character. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for startIndex is negative. |

Returns an empty text range:
- if the given string cannot be found in the text.
- if the given start index is beyond the length of the entire text.