Instance |
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The InstanceBinding type exposes the following members.

Name | Description | |
---|---|---|
![]() | InstanceBinding | Constructs an empty instance binding. |
![]() | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed. |

Name | Description | |
---|---|---|
![]() | Categories | Retrieve or set the categories to which a parameter definition will be bound. (Inherited from ElementBinding ) |
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.