Instance |
The InstanceBinding object is used to signify a binding between a parameter definition and a parameter on each instance of an element, such as a wall.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB Binding
Autodesk.Revit.DB ElementBinding
Autodesk.Revit.DB InstanceBinding
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The InstanceBinding type exposes the following members.

Name | Description | |
---|---|---|
![]() | InstanceBinding | Constructs an empty instance binding. |
![]() | InstanceBinding(CategorySet) | Constructs an instance binding with the set of categories passed. |

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|

Once bound the parameter will appear on all instance of the element and changing the parameter on any one single instance will not change the value on any other instance.