IndexBuffer Constructor


Index Buffer Constructor

Constructs the index buffer with the given capacity, measured in short integers.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IndexBuffer(
	int sizeInShortInts
)

Parameters

sizeInShortInts Int32
The number of short integers that the buffer can contain.
Exceptions
Exception Condition
InvalidOperationException This IndexBuffer is not available because Revit is not currently rendering. In general, this IndexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer.
See Also