WiringType Property


Wire Wiring Type Property

The wiring type(arc or chamfer) for the wire.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public WiringType WiringType { get; set; }

Property Value

WiringType
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the WiringType is arc, the shape of the wire depends on the number of points - it may be linear, a circular arc, or a spline.
See Also