Selection Pick |
Prompts the user to pick a point on the active work plane using specified snap settings.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- snapSettings ObjectSnapTypes
- Specifies the object snap types for this pick. Multiple object snap types can be combined with "|"
Return Value
XYZThe point picked by user.
Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Exception | Condition |
---|---|
InvalidOperationException | Thrown when no work plane set in current view. |
OperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode. |
ForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update. |

Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.
Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.