Rebar Get |
Gets the rebar splice at the specified bar end - 0 for start, 1 for end.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- barEnd Int32
- The bar end for which the rebar splice is needed - 0 for start, 1 for end.
Return Value
RebarSpliceReturns the rebar splice at the specified bar end - 0 for start, 1 for end.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | barEnd must be 0 or 1. |

In order to splice a rebar or unify existing spliced rebars there are utility functions in RebarSpliceUtils class.