View |
A render node that represents a view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ViewNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from RenderNode ) |
![]() | LevelOfDetail | The level of detail the view is going to be rendered at. |
![]() | NodeName | A readable name of the output node. (Inherited from RenderNode ) |
![]() | ViewId | The Id of the view element. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCameraInfo | Information about the observation point (the camera) of the view. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

See also: [!:Autodesk::Revit::DB::IExportContext::OnViewBegin] .