Text |
Returns the maximum width the text element can be created with.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- cdda Document
- A document containing the new text element's type
- typeId ElementId
- Id of the text type
Return Value
DoubleThe maximum allowed width in paper space [ft].

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Note that it is not necessarily a constant; it can be affected by properties of the text type, such as the width factor.