DuctFittingAndAccessoryData Class


Duct Fitting And Accessory Data Class

The input data used by external servers for calculation of the duct fitting and duct accessory coefficient.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Mechanical DuctFittingAndAccessoryData

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class DuctFittingAndAccessoryData : IDisposable

The DuctFittingAndAccessoryData type exposes the following members.

Properties
Name Description
Public property Density The air density for the duct fitting or duct accessory, Units: kg/ft^3.
Public property DynamicViscosity The dynamic viscosity of air for the duct fitting or duct accessory, Units: (kg/(ft·s)).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Origin The origin position of the duct fitting or duct accessory.
Public property PartType The part type of the duct fitting or duct accessory.
Public property ServerGUID The GUID of the duct fitting or duct accessory.
Public property SystemClassification The system classification of the duct fitting or duct accessory.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DuctFittingAndAccessoryData
Public method GetAllConnectorData Gets the connector data of the pipe fitting or pipe accessory.
Public method GetEntity Returns an Entity of the Schema of the serverGUID. or an invalid entity otherwise.
Public method GetFamilyInstanceId Gets the Id of the fiting or accessory instance
Top
Remarks
A FamilyInstance is the input data for the calculation,
See Also