ImageTypeOptions Constructor (String, Boolean, ImageTypeSource)


Image Type Options(String, Boolean, Image Type Source) Constructor

Constructs a new instance of the ImageTypeOptions object.

The provided string path must specify a local file. The path can be absolute or relative to the project's location.

This constructor saves an additional setting that indicates whether the imagetype will be a link or an import.


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ImageTypeOptions(
	string path,
	bool useRelativePath,
	ImageTypeSource sourceType
)

Parameters

path String
The file path that specifies the image to be used.
useRelativePath Boolean
True if ImageType should use a relative path, false otherwise.
sourceType ImageTypeSource
Specifies the image type source. Valid values are 'Import' and 'Link'.
Exceptions
Exception Condition
ArgumentException The ImageType source is not correct. Only Link or Import values are allowed.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also