Create Method


Wall Sweep Create Method

Creates a new wall sweep or reveal.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static WallSweep Create(
	Wall wall,
	ElementId wallSweepType,
	WallSweepInfo wallSweepInfo
)

Parameters

wall Wall
The wall upon which to create the new sweep or reveal.
wallSweepType ElementId
The wall sweep or reveal type.
wallSweepInfo WallSweepInfo
The information that describes the new wall sweep or reveal.

Return Value

WallSweep
The new wall sweep.
Exceptions
Exception Condition
ArgumentException The wall sweep info represents a fixed wall sweep. Fixed wall sweeps may not be assigned to standalone wall sweep elements. -or- The WallSweepInfo id must be set to -1 for a non-fixed wall sweep. -or- wall may not host a wall sweep or reveal.
ArgumentNullException A non-optional argument was null
Remarks
The wall sweep's profile and type are taken from the wall sweep type properties. The values set in the WallSweepInfo are ignored.
See Also