Element |
The event arguments used by the ElementTypeDuplicated event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPostEventArgs
Autodesk.Revit.DB.Events RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events ElementTypeDuplicatedEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPostEventArgs
Autodesk.Revit.DB.Events RevitAPIPostDocEventArgs
Autodesk.Revit.DB.Events ElementTypeDuplicatedEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementTypeDuplicatedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | NewElementTypeId | The id of the newly duplicated ElementType. |
![]() | NewName | The name of the newly duplicated ElementType. |
![]() | OriginalElementTypeId | The id of the element type that is duplicated. |

Name | Description | |
---|---|---|