DesignToFabricationMappingResult Enumeration


Design To Fabrication Mapping Result Enumeration

Possible results from setting the mapping from Family symbols to Fabrication part types.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum DesignToFabricationMappingResult
Members
Member name Value Description
InvalidFabricationPartType 3 Failed because there was an invalid Fabrication part type identifier or an identifier that did not exist in the mappings.
InvalidFamilySymbol 2 Failed because there was an invalid Family symbol identifier or an identifier that did not exist in the mappings.
Success 0 Setting the mappings for conversion was successful.
Undefined 1 Failed because the map contained no entries.
UnsupportedFabricationPartType 5 Failed due to attempting to convert an unsupported Fabrication part type. It is expected to be either valve, strainer, damper, smoke detector, end cap, or other in line component.
UnsupportedFamilySymbol 4 Failed due to attempting to convert an unsupported Family symbol. It is expected to be either valve, strainer, damper, smoke detector, end cap, or other in line component.
See Also