BuildingEnvelopeAnalyzer Class


Building Envelope Analyzer Class

Analyzes which elements are part of the building envelope, the building elements exposed to the outside.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis BuildingEnvelopeAnalyzer

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class BuildingEnvelopeAnalyzer : IDisposable

The BuildingEnvelopeAnalyzer type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member Create Creates a new analyzer.
Public method Dispose Releases all resources used by the BuildingEnvelopeAnalyzer
Public method GetBoundingElements Returns the collection of building elements exposed to the outside forming the building envelope.
Public method GetBoundingElementsForSpaceVolume Returns the collection of bounding building elements for an enclosed space volume.
Public method GetCenterPointsForConnectedGridCellsInSpaceVolume Returns the collection of connected cells in an enclosed space volume.
Top
Remarks
This class uses a combination of ray-casting and flood-fill algorithms in order to find the building elements that are exposed to the outside of the building. This method can also look for the bounding building elements for enclosed space volumes inside the building.
See Also