GetStructuralSection Method


Structural Section Utils Get Structural Section Method

Return structural section from element.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static StructuralSection GetStructuralSection(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document that owns the family for beam, brace or structural column.
elementId ElementId
ID of family symbol or family instance for beam, brace or structural column.

Return Value

StructuralSection
Structural section returned if element have one. For elements that do not have structural section or can not have structural section will be returned.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Only beams, braces and structural columns can have structural section associated with it.
See Also