SetDuplicateTypeNamesHandler Method


Copy Paste Options Set Duplicate Type Names Handler Method

Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDuplicateTypeNamesHandler(
	IDuplicateTypeNamesHandler handler
)

Parameters

handler IDuplicateTypeNamesHandler
The duplicate type names handler.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also