BoundaryValidation Class


Boundary Validation Class

Curve loop validators.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BoundaryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class BoundaryValidation : IDisposable

The BoundaryValidation type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the BoundaryValidation
Public method Static member IsValidBoundaryOnSketchPlane
Public method Static member IsValidBoundaryOnView
Public method Static member IsValidHorizontalBoundary
Top
See Also