FabricationPartSizeMap Constructor (String, Double, Double, Boolean)


Fabrication Part Size Map(String, Double, Double, Boolean) Constructor

Creates a new instance of the FabricationPartSizeMap class.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FabricationPartSizeMap(
	string size,
	double widthDiameter,
	double depth,
	bool isProductList
)

Parameters

size String
The size display string for the straight that can be used by the user interface.
widthDiameter Double
The width or diameter of the straight.
depth Double
The depth of the straight.
isProductList Boolean
Set if the straight a product list or not.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also