PipeFittingAndAccessoryPressureDropData Class


Pipe Fitting And Accessory Pressure Drop Data Class

The input and output data used by external servers for calculation of the pipe fitting and pipe accessory pressure drop.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Plumbing PipeFittingAndAccessoryPressureDropData

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PipeFittingAndAccessoryPressureDropData : IDisposable

The PipeFittingAndAccessoryPressureDropData type exposes the following members.

Properties
Name Description
Public property CalculationType The calculation type, a bitmask of FittingAndAccessoryCalculationType.
Public property IsCurrentEntityValid True if the current settings stored in the entity is valid.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PipeFittingAndAccessoryPressureDropData
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetPipeFittingAndAccessoryData Returns the fitting and accessory information
Public method GetPresureDropItems Returns the pressure drop items
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetDefaultEntity Stores the default entity in the data.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also