UpdaterInfo Class


Updater Info Class

Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB UpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class UpdaterInfo : IDisposable

The UpdaterInfo type exposes the following members.

Properties
Name Description
Public property AdditionalInformation Additional information about the updater.
Public property ApplicationName Name of the application that owns the updater.
Public property IsOptional Whether the updater is optional or not.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property UpdaterName Name of the updater.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the UpdaterInfo
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also