Unload Method


Revit Link Type Unload Method

Unloads the Revit link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Unload(
	ISaveSharedCoordinatesCallback callback
)

Parameters

callback ISaveSharedCoordinatesCallback
A callback indicating what to do if Revit encounters links which have changes in shared coordinates. If , Revit will not save any shared coordinates changes to the link before unloading.
Exceptions
Exception Condition
ForbiddenForDynamicUpdateException The function is not permitted during dynamic update.
InvalidOperationException This RevitLinkType is not a top-level link. -or- Revit could not save shared coordinates changes to the link or one of its nested links. -or- There is a transaction phase left open (such as a transaction, sub-transaction of transaction group) at the time of invoking this method. -or- The document is read-only. It cannot be modified. -or- The document is in an edit mode or is in family mode. -or- Revit cannot link a cloud model to non-cloud model
RevitServerInternalException Could be for any of the reasons that failed on service side.
RevitServerUnauthenticatedUserException User is not signed in with Autodesk id.
RevitServerUnauthorizedException User is not authorized to access the specified cloud model.
Remarks

This function regenerates the document.

The document's Undo history will be cleared by this command. As a result, this command and others executed before it cannot be undone. All transaction phases (e.g. transactions transaction groups and sub-transaction) that were explicitly started must be finished prior to calling this method.

See Also