SketchEditScope Class


Sketch Edit Scope Class

A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB SketchEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SketchEditScope : EditScope

The SketchEditScope type exposes the following members.

Constructors
Name Description
Public method SketchEditScope Instantiates a SketchEditScope object.
Top
Properties
Name Description
Public property IsActive Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
(Inherited from EditScope )
Public property IsPermitted Tells if the edit scope is permitted to start.
(Inherited from EditScope )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from EditScope )
Top
Methods
Name Description
Public method Cancel Cancels the edit scope.
(Inherited from EditScope )
Public method Commit Finishes the edit scope.
(Inherited from EditScope )
Public method Dispose
(Inherited from EditScope )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsElementWithoutSketch Validates if an element can have a sketch but currently does not.
Public method IsSketchEditingSupported Checks whether sketch can be edited.
Public method IsSketchEditingSupportedForSketchBasedElement Checks whether the element supports sketch editing.
Public method Start Starts a sketch edit mode.
Public method StartWithNewSketch Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Start/end of a SketchEditScope will start/end a transaction group. After a SketchEditScope is started, an application can start transactions and edit the sketch. Individual transactions the application creates inside SketchEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into SketchEditScope constructor.
See Also