SketchEditScope Class


Sketch Edit Scope Class

A SketchEditScope allows an application to create and maintain an editing session for a Sketch.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB SketchEditScope

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SketchEditScope : EditScope

The SketchEditScope type exposes the following members.

Constructors
Name Description
Public method SketchEditScope Instantiates a SketchEditScope object.
Top
Properties
Name Description
Top
Methods
Name Description
Public method IsElementWithoutSketch Validates if an element can have a sketch but currently does not.
Public method IsSketchEditingSupported Checks whether sketch can be edited.
Public method IsSketchEditingSupportedForSketchBasedElement Checks whether the element supports sketch editing.
Public method Start Starts a sketch edit mode.
Public method StartWithNewSketch Starts a sketch edit mode for an element which, at this moment, doesn't have a sketch.
Top
Remarks
Start/end of a SketchEditScope will start/end a transaction group. After a SketchEditScope is started, an application can start transactions and edit the sketch. Individual transactions the application creates inside SketchEditScope will not appear in the undo menu. All transactions committed during the edit mode will be merged into a single one which will bear the given name passed into SketchEditScope constructor.
See Also