ParameterMapIterator Class


Parameter Map Iterator Class

An iterator to a map relating a parameter name (the key, a String) to a parameter.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ParameterMapIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ParameterMapIterator : APIObject, 
	IEnumerator

The ParameterMapIterator type exposes the following members.

Constructors
Name Description
Public method ParameterMapIterator For Internal Use Only.
Top
Properties
Name Description
Public property Current Retrieves the item that is the current focus of the iterator.
Public property Key Retrieves the key that is the current focus of the iterator.
Top
Methods
Name Description
Public method MoveNext Move the iterator one item forward.
Public method Reset Bring the iterator back to the start of the map.
Top
See Also