ConvertRebarInSystemToRebars Method


Path Reinforcement Convert Rebar In System To Rebars Method

Converts all RebarInSystem elements owned by the input PathReinforcement to equivalent Rebar elements.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> ConvertRebarInSystemToRebars(
	Document doc,
	PathReinforcement system
)

Parameters

doc Document
The document.
system PathReinforcement
A PathReinforcement element in the document.

Return Value

IList ElementId
The ids of the newly created Rebar elements.
Exceptions
Exception Condition
ArgumentException The element system was not found in the given document. -or- system does not host Rebar.
ArgumentNullException A non-optional argument was null
See Also