Wall Remove |
Removes an attachment at the top or base of a wall, if there is one.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

public void RemoveAttachment(
ElementId targetId,
AttachmentLocation attachmentLocation
)
Parameters
- targetId ElementId
- Target element id.
- attachmentLocation AttachmentLocation
- The attachment location.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |