Load |
Indicates if the provided orientation is permitted for this load.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- orientTo LoadOrientTo
- Load orientation to check.
Return Value
BooleanTrue if provided orientation type is permitted for this load, false if not.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |

For hosted load only LoadOrientTo.Project and LoadOrientTo.HostLocalCoordinateSystem are permitted. For non-hosted load only LoadOrientTo.Project and LoadOrientTo.WorkPlane are permitted. To determine if load is hosted use IsHosted property.