CategorySet Class


Category Set Class

A set that can contains Category objects.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CategorySet : APIObject, 
	IEnumerable

The CategorySet type exposes the following members.

Constructors
Name Description
Public method CategorySet Initializes a new instance of the CategorySet class
Top
Properties
Name Description
Public property IsEmpty Test to see if the set is empty.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Size Returns the number of categories that are in the set.
Top
Methods
Name Description
Public method Clear Removes every item from the set, rendering it empty.
Public method Contains Tests for the existence of a category within the set.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Erase Removes a specified category from the set.
Public method ForwardIterator Retrieve a forward moving iterator to the set.
Public method GetEnumerator Retrieve a forward moving iterator to the set.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Insert Insert the specified category into the set.
Public method ReverseIterator Retrieve a backward moving iterator to the set.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also