FileImportedEventArgs Class


File Imported Event Args Class

The event arguments used by the FileImported event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FileImportedEventArgs : RevitAPIPostDocEventArgs

The FileImportedEventArgs type exposes the following members.

Properties
Name Description
Public property Format Identifies the import format, e.g. DWG or image.
Public property ImportedInstanceId The ElementId of the imported instance that represents the imported object(s) after a successful import. It could be used for further manipulation of that instance.
Public property Path Path of the source file that was imported.
Top
Methods
Name Description
Top
See Also