SetThermalProperties Method


Family Symbol Set Thermal Properties Method

Sets the thermal properties for the given FamilySymbol.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetThermalProperties(
	FamilyThermalProperties thermalProperties
)

Parameters

thermalProperties FamilyThermalProperties
The new thermal properties. If , this unsets custom thermal properties for this FamilySymbol.
Exceptions
Exception Condition
ArgumentException The thermal properties are not valid for assignment.
InvalidOperationException This FamilySymbol does not contain thermal properties.
See Also