Export |
A value used to represent the info stored in the ExportLayerTable .

System Object
Autodesk.Revit.DB ExportLayerInfo
Autodesk.Revit.DB ExportLayerInfo
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The ExportLayerInfo type exposes the following members.

Name | Description | |
---|---|---|
![]() | ExportLayerInfo | Constructs a new ExportLayerInfo with default values. |

Name | Description | |
---|---|---|
![]() | CategoryType | The category type which this layer belongs to. |
![]() | ColorName | The color name stored in value. For IFC export, the naming is to match the "colornumber" setting -- really, this stores a string that generates the colorNumber (for formats that don't use the color but need a second entry.) |
![]() | ColorNumber | The color number stored in value. |
![]() | CutColorNumber | The cut color number stored in value. |
![]() | CutLayerName | The cut layer name stored in value. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LayerName | The layer name stored in value. |

Name | Description | |
---|---|---|
![]() | AddCutLayerModifier | Adds a cut layer modifier to the layer info. |
![]() | AddLayerModifier | Adds a project layer modifier to the layer info. |
![]() | ClearCutLayerModifiers | Clears all the cut layer modifiers stored in the layer info. |
![]() | ClearLayerModifiers | Clears all the project layer modifiers stored in the layer info. |
![]() | Dispose | Releases all resources used by the ExportLayerInfo |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetCutLayerModifiers | Gets all the cut layer modifiers from the layer info. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLayerModifiers | Gets all the project layer modifiers from the layer info. |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | RemoveCutLayerModifier | Removes a cut layer modifier from the layer info. |
![]() | RemoveLayerModifier | Removes a project layer modifier from the layer info. |
![]() | SetCutLayerModifiers | |
![]() | SetLayerModifiers | |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |