Text |
An object that is used to identify a range of characters in a FormattedText .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The TextRange type exposes the following members.

Name | Description | |
---|---|---|
![]() | TextRange | Constructs a TextRange with default values for start and length. |
![]() | TextRange(TextRange) | Constructs a copy of the input TextRange object. |
![]() | TextRange(Int32, Int32) | Constructs a TextRange with input start and length. |

Name | Description | |
---|---|---|
![]() | End | The index of the first character after the end of the range |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | Length | The length of the range. |
![]() | Start | The start index of a range within the FormattedText . |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the TextRange |

A TextRange consists of a start, which is a zero-based index into the text, and a length, which is the number of characters in the range. The length can be zero.