Family |
Provides access to the Autodesk::Revit::DB::ElementId^ stored in the given family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- familyParameter FamilyParameter
Return Value
ElementIdThe Autodesk::Revit::DB::ElementId^ contained in the parameter.Returns an invalid element id if the storage type of the input argument is Autodesk::Revit::DB::ElementId^ type or this parameter has no value.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"familyParameter"-is . |
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid, |