Classification |
A collection of ClassificationEntry objects that make up the classification table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ClassificationEntries type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from KeyBasedTreeEntries ) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from KeyBasedTreeEntries ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | FindEntry | Finds the KeyBasedTreeEntry associated with the given key value. (Inherited from KeyBasedTreeEntries ) |
![]() | GetBasicIEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries ) |
![]() | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from KeyBasedTreeEntries ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetKeyBasedTreeEntriesIterator | Returns a KeyBasedTreeEntriesIterator that iterates through the collection. (Inherited from KeyBasedTreeEntries ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() ![]() | LoadClassificationEntriesFromFile | Loads the contents of a classification text file into the provided KeyBasedTreeEntriesLoadContent. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |