GetFailureMessages Method


Key Based Tree Entries Load Results Get Failure Messages Method

Get all error or warnings created while attempting to load KeyBasedTreeEntries.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<FailureMessage> GetFailureMessages()

Return Value

IList FailureMessage
A collection of FailureMessage objects, if any errors or warnings were encountered while loading and building the KeyBasedTreeEntries.
Remarks

Revit does not post these warnings. They are provided as a convenience to the API user, who may wish to post them.

The information in the warnings is also captured in the other error functions of KeyBasedTreeEntriesLoadResults.

See Also