Direction Property


Reference Plane Direction Property

The direction of the reference plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ Direction { get; set; }

Property Value

XYZ
Exceptions
Exception Condition
ArgumentNullException When setting this property: A non-optional argument was null
ArgumentOutOfRangeException When setting this property: newDir has zero length.
Remarks
When setting this property, an exception will be thrown if the direction vector is not perpendicular to the normal vector.
See Also