Create Method (Document, IList(Curve), ElementId, ElementId, Boolean)


Wall Create(Document, IList Curve , Element Id, Element Id, Boolean) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Wall Create(
	Document document,
	IList<Curve> profile,
	ElementId wallTypeId,
	ElementId levelId,
	bool structural
)

Parameters

document Document
profile IList Curve
wallTypeId ElementId
levelId ElementId
structural Boolean

Return Value

Wall
See Also