Rebar |
Returns a reference that corresponds to the face to which the RebarConstraint is attached specified by the targetIndex. The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover'.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- targetIndex Int32
- The index of the target. Should be between 0 and NumberOfTargets().
Return Value
ReferenceRequested reference.

Exception | Condition |
---|---|
ArgumentException | targetIndex is out of range. |
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'. |