IntersectWithCurve Method


Solid Intersect With Curve Method

Calculates and returns the intersection between a curve and this solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public SolidCurveIntersection IntersectWithCurve(
	Curve curve,
	SolidCurveIntersectionOptions options
)

Parameters

curve Curve
The curve.
options SolidCurveIntersectionOptions
The options. If NULL, the default options will be used.

Return Value

SolidCurveIntersection
The intersection results.
Exceptions
Exception Condition
ArgumentException The input curve is not bound. -or- The input solid is not a closed volume.
ArgumentNullException A non-optional argument was NULL
See Also